How can we help you?

Learn how to set up, customize, and troubleshoot Keystone Themes.

Server requirements

Estimated reading: 2 minutes 55 views

For optimal performance with any of our WordPress themes, we highly recommend ensuring that your hosting provider supports WordPress 6 or later, PHP version 7.4 or higher (WordPress now recommends PHP 7.4, see more details), and MySQL version 5.7 or newer. For a detailed list of recommended PHP extensions, please refer to the Hosting Handbook.

It’s crucial to note:
PHP versions older than 7.3+ and MySQL versions older than 5.6 are no longer actively supported, with many of them reaching End Of Life and consequently not being maintained anymore. Therefore, utilizing outdated and unsupported versions of MySQL and PHP could leave your site vulnerable to security risks.

In most cases, updating the PHP version requires assistance from your hosting provider. The upgrade process is typically straightforward and shouldn’t affect your website or incur any additional charges. Here’s a template you can use to request these updates from your host:

"Hello,

I'm interested in running WordPress on my website, and I'd like to inquire if my account supports the following:

PHP 7.4 or higher

MySQL 5.7 or higher OR MariaDB 10.3 or higher

Nginx or Apache with mod_rewrite module

HTTPS support

Additionally, could you please adjust the following limits to meet the minimum requirements:
max_execution_time: 240
memory_limit: 256M
post_max_size: 64M
upload_max_filesize: 64M
max_input_time: 120

PHP Configuration limits:
Issues like failed demo content imports and similar problems often stem from excessively low PHP configuration limit settings. You can either adjust these limits yourself or contact your web host to request the following minimums:

  • memory_limit: 256M
  • max_input_vars: 3000
  • max_execution_time: 240
  • max_input_time: 120
  • post_max_size: 64M
  • upload_max_filesize: 64M
  • allow_url_fopen: ON
  • asp_tags: OFF
  • cURL: ON
Share this Doc

Server requirements

Or copy link

CONTENTS